読者です 読者をやめる 読者になる 読者になる

Keep on moving

あんまりまとまってないことを書きますよ

XCode5.1環境でansibleをいれる

ansible

version: 0.1
env:MacOSX Maverics 10.9.2
XCode: 5.1

Ansibleを入れようとしたら、以下のエラーメッセージがでた。

-clang: error: unknown argument: '-mno-fused-madd'


どうやら、そのままでは入らないっぽいです。困ったので検索したらぴったりの記事がありました。

http://stackoverflow.com/questions/22390655/ansible-installation-clang-error-unknown-argument-mno-fused-madd

以下のように実行することで解決。

sudo ARCHFLAGS=-Wno-error=unused-command-line-argument-hard-error-in-future pip install ansible

先人に感謝。